2017-11-14

Wichtige Info zu Firefox 57

Am 14.11.2017 wurde Firefox 57 veröffentlicht. Diese Version unterstützt ältere Browser-Erweiterungen nicht mehr. Um Firefox 57 zusammen mit Citavi zu verwenden, brauchen Sie die aktuelle Picker-Version aus dem Firefox-Store und Citavi 5.6 oder 5.7.

Lesen Sie bitte unseren FAQ-Artikel.